[NBLUG/talk] Grub install problem from FreeBSD

ShadowEyez shadoweyez at hotpop.com
Thu Apr 8 20:41:40 PDT 2004

I'm running a new system with a fresh install of FreeBSD 5.2.1 on i386, with GCC 3.3.3 and have been trying to install the GRUB 0.94 boot loader.
Got the .tar.gz file, untarred it, and ran the configure script from the grub-0.94 directory with no special options.  Typed make and ran into a message saying couldn't compile stage1.  I looked around at all the makefiles in the directories (stage1, stage2, utils, docs, grub) and did make and then make install in each dir.  After doing this in the grub directory, I could run the grub program, and after going this in the docs directory I could run man pages, and after make and make install in the utils directory I could (try) and run grub-install and grub-terminfo, meaning these programs and docs compiled nicley.  It's the stage1 and 2 directories that are giving me problems.

After typing just make (not make install) at the base (grub-0.94) directory make gives a message: don't know how to make stage1. Stop.
I go into the stage1 directory and try make there with the exact same message: don't know how to make stage1. Stop.
I go into the stage2 directory and try make there and make says: don't know how to make pre_stage2. Stop.

I try to install grub nonetheless and after running grub-install /dev/ad0a1a (the partision I want grub on) I get the message: /usr/local/share/grub/i386-unknown/stage1: Not found.
Needless to say, no luck installing grub.  I have tried make clean in all the directories, and tried again with no avial.  The man pages and online docs were not helpful in this regard (although they were in other times I've used grub).  My guess is, once the pre_stage2 compiles, stage1 will compile, and the stage1 file will be found by the grub installer?  How can I get this pre stage 2 to compile, what am I missing?  Am I doing something wrong?  I am not a developer, but did peek in the makefiles, configure scripts, and installer scripts and did not find anything strange.

How can I install grub?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://nblug.org/pipermail/talk/attachments/20040408/952cb71a/attachment.html

More information about the talk mailing list