[NBLUG/talk] Volume control failure

Lincoln Peters sampln at sbcglobal.net
Sat Apr 24 10:39:39 PDT 2004

Something strange seems to be going on with my sound since I upgraded to
the 2.6 kernel (although I hadn't noticed it until recently since I
rarely use sound).  I'm using ALSA with OSS emulation, so that I can
(hopefully) take adventage of some of ALSA's advanced features without
breaking compatibility with OSS applications.

I can get sound without any difficulty, but all volume controls except
for the ones built into my speakers have stopped working!  I think I've
loaded all of the correct kernel modules, but I still can't control the
volume.  I have the following audio and audio-related modules set to
load at boot time:

snd_pcm_oss 53860 2 - Live 0xe345e000
snd_mixer_oss 19840 2 snd_pcm_oss, Live 0xe0c09000
snd_emu10k1 98244 4 - Live 0xe0b73000
snd_rawmidi 25120 1 snd_emu10k1, Live 0xe0b20000
snd_pcm 95268 2 snd_pcm_oss,snd_emu10k1, Live 0xe0b3d000
snd_timer 25860 1 snd_pcm, Live 0xe0b04000
snd_seq_device 8136 2 snd_emu10k1,snd_rawmidi, Live 0xe0ae3000
snd_ac97_codec 63044 1 snd_emu10k1, Live 0xe0b0f000
snd_page_alloc 11332 2 snd_emu10k1,snd_pcm, Live 0xe0adf000
snd_util_mem 4480 1 snd_emu10k1, Live 0xe0adc000
snd_hwdep 9504 1 snd_emu10k1, Live 0xe097c000
snd 52772 12 snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep, Live 0xe0aed000
soundcore 9888 4 snd, Live 0xe0978000

I'm using Debian/unstable and Kernel 2.6.5 (installed manually).  Am I
missing something?

Lincoln Peters
<sampln at sbcglobal.net>

[Washington, D.C.] is the home of... taste for the people -- the big,
the bland and the banal.
		-- Ada Louise Huxtable

More information about the talk mailing list