[NBLUG/talk] HP 5200c scanner, Fedora Core 2, 2.6.5 kernel

Mark Street mark at oswizards.com
Mon Jun 14 09:05:06 PDT 2004

Let's think this through from a low level to a higher level.  We know that 
jumping from a 2.4 to a 2.6 kernel can introduce unforeseen effects.

Let's look at /etc/modules.conf
Let's look at /etc/modprobe.conf

Let's see output of the /sbin/lsusb command when the scanner is plugged in.

Let's see a listing of the drivers available for the usb scanners from

and maybe the file names from the 'core' and 'host' directories

Why?  We need to see what modules your system is loading, and in what order 
they are loaded in.  We also need to know if those modules exist by their 
given name or some other name.

On Monday 14 June 2004 07:23, Dave Sisley wrote:
> Hello.
> Having just upgraded from FC1 -> FC2, one of the more stubborn
> problems I am having is regaining use of my scanner.  It was working
> fine before my upgrade.  FC2 uses a 2.6.5 kernel.
> I've been googling this quite a bit, and none of the few solutions
> seem to work.
> I've tried:
> - reinstalling sane-frontends, sane-backends, xsane and xsane-gimp
> - editing /etc/sane.d/hp.conf in a number of (unsuccessful) ways
> Currently, the scanner is detected by sane-find-scanner:
> "found USB scanner (vendor=0x03f0, product=0x0401) at libusb:002:002"
> Running xsane as myself (lowly user) returns an error message that it
> can't find the device.  Running it as root, the program will start,
> but I when I try to scan I get this message:
> "Error during read: Error during device I/O."  I've been seeing this
> message consistently since my upgrade.  Before I reinstalled the
> packages mentioned above, I was able to get xsane to run as a lowly
> user, but would still get the I/O error.
Mark Street, RHCE
Key fingerprint = 3949 39E4 6317 7C3C 023E  2B1F 6FB3 06E7 D109 56C0
GPG key http://www.oswizards.com/pubkey.asc

More information about the talk mailing list