[NBLUG/talk] Making esoteric /dev entries

Lincoln Peters sampln at sbcglobal.net
Mon Jan 17 21:16:39 PST 2005

On Mon, 2005-01-17 at 20:27 -0800, A'fish'ionado wrote:
> I'm trying to use an oddball USB device (the IR tower from the Lego
> Mindstorms set). Fortunately, there's a module for it in the 2.6
> kernel. I can load the module just fine, and it seems to talk to the
> device. However, there's no entry under /dev for the device (there's
> supposed to be an entry as /dev/usb/legousbtower0).
> I've been playing with Debian's MAKEDEV script (why they had to name
> it with all caps is beyond me), but it only seems to understand how to
> make entries for devices in a list hardcoded into the script. I've
> tried every option I can find documented, and it won't create an entry
> for my device.

I've noticed that the process by which newer versions of Debian/Sarge
try to detect and configure hardware is a bit weird, to put it lightly.
I discovered that, at least in my case, there were certain types of
devices that MAKEDEV was supposed to know how to create, but after I ran
it, my /dev directory was unchanged.

My best guess for your situation would be to create a new directory,
let's call it /dev2, mount a devfs filesystem into that directory, and
see if you can find your IR tower somewhere in there (I'm fairly sure
that devfs support exists in Debian/Sarge's stock 2.6 kernel).  It's a
bit ugly, but it might work.

Lincoln Peters
<sampln at sbcglobal.net>

	The fountains of knowledge, where everyone goes to drink.

More information about the talk mailing list