[NBLUG/talk] Compiling and installing a Debian Kernel

Daniel Kinon kinon at sonoma.edu
Mon Jan 31 11:20:39 PST 2005

Hey Guys,
   I have recently been working with debian and have finally come across
functionality for which I must compile my own kernel.  The
functionality I was looking to get was debian's bootsplash, this is mostly
negligible information since I got bootsplash to work.  However, I can't
seem to get my kernel to boot.  I will go through the steps I went through
to compile and install my kernel and then I'll give you the error messages
I have been recieving:

1) apt-get install kernel-source-2.6.8
2) untared the source package in /usr/src/
3) patched the kernel with the boot splash patch for 2.6.8 kernel
     patch -p1 <bootsplash-3.1.6-2.6.8.diff
4) make menuconfig, following are the only changes I made to the config
    codematurity -> Pentium M  (I'm running a Fujitsu 7010 btw (M -
    filesystems -> ext3 (made it part of the kernel instead of a module)
bootsplash -> enable bootsplash
5) make-kpkg buildpackage -rev Custom.1 kernel_image
6) installed .deb package created by previous step
7) mkinitrd -k -o /boot/initrd.img-2.6.8-custom -r /dev/hda4
    ran the following:
    splash -s -f
/etc/bootsplash/themes/newlinux/config/bootsplash-1024x768.cfg >>
     all that does is append the particular bootsplash them you want to
the end of the initrd.img that you want to use.
8) updated grub with new kernel
9) rebooted

So when I rebooted everything seemed to work.
Grub found the initrd and put up the bootsplash image....
then everything got weird.  I couldn't read what happened at first cause
it all went to fast.  After that it just started printing out a bunch of
the same error message:
modeprobe: FATAL: Could not load /lib/modules/3.6.8/modules.dep : no such
file or directory
then I got a kernel panic and that is where my story ends.

I checked to make sure that the file existed and it does... and I know
that my / is being read because I didn't create a different partition for
/boot so if the initrd.img is being read (which it most definitely is) it
should beable to read that file is says it can't find.
I tried looking online for help but haven't found any.  Infact all the
help I have found says that all the steps I have done are correct.  Any
ideas as to what I have done wrong?

More information about the talk mailing list