[NBLUG/talk] Networking newbie

Ron Wickersham rjw at alembic.com
Mon Jan 9 23:30:21 PST 2006

hi William,

your subnet mask doesn't match the other network parameters as the error
message pointed out.

i think you intended to make a subnet with 254 usable addresses which in
CIDR terms is a /24 (or historical terms was called a Class C).

> eth0      Link encap:Ethernet  HWaddr 00:50:8D:53:57:B3
>           inet addr:  Bcast:  Mask:

your inet addr is ok, but the broadcast address is not.  it should be
the same as your address with the last octet 255, so you need to type

ifconfig eth0 broadcast

and that will fix it up (won't fix it when it reboots but that's another
issue you'll have to figure out based on how your distribution).

> subnet netmask {
>         range;

we need to fix this up as well.

the subnet name starts at the beginning of the subnet (you have the machine's
host address, and the netmask here is ok, and the range of addresses you've
assigned is ok since they're in the subnet you're configuring.

change it so it says

subnet netmask {


on the other hand if you wanted to make a giant subnet with 16 million
addresses for _all_ your machines ;-)

>           inet addr:  Bcast:  Mask:

would have to be

ifconfig eth0 broadcast netmask

and the dhcp config netmask:

subnet netmask {

would be subnet netmask


the host address is in both the large and the small subnet,
and the subnet comes out the same as well.

the big difference is the subnet mask tells the machine how many addresses
are in the subnet.


i've also found that linux computes the wrong broadcast address when given
the host address and netmask when you're configuring any size subnet in
the 10. network.   linux always assumes that you want the full class A
or /8 subnet even when you have specified another netmask.   this bug has
been there for a long time and i don't know if it's fixed yet, but
obviously not in your distribution.    (the same error never was in
OpenBSD or Solaris).


/~\  The ASCII Ribbon Campaign
\ /    No HTML/RTF in email
 X     No Word docs in email
/ \  Respect for open standards

On Mon, 9 Jan 2006, A'fish'ionado wrote:

> Date: Mon, 9 Jan 2006 23:05:11 -0800
> From: A'fish'ionado <afishionado at gmail.com>
> To: "General NBLUG chatter about anything Linux, answers to questions,
>     etc." <talk at nblug.org>
> Subject: Re: [NBLUG/talk] Networking newbie
> Hello,
> The idea behind having the connection routed through one box was to
> only have to configure a firewall at one place. I'd rather not have to
> go through and install firewalls on the rest of the family's Win98
> boxen. :-P
> I would *love* to go with Sonic.net, but the $30/month (after the
> first six months) is more than my parents are going to pay, and since
> I'm not paying for anything right now (no job... anybody wanna hire an
> intern to code this summer?), I don't get to make that decision.
> Now, to see if I have any idea what I'm doing, I grabbed a Netgear hub
> from the Computer Recycling Center, and tried to network two Debian
> boxen together. I didn't find a DHCP server installed by default
> (natch, it's Debian, so it's not plug-n-play), so I fired up Aptitude
> and grabbed the dhcp3 client and daemon.
> I Googled for instructions, and got part way to a working system. :-)
> ifconfig -a showed, among other things:
> eth0      Link encap:Ethernet  HWaddr 00:50:8D:53:57:B3
>           inet addr:  Bcast:  Mask:
>           inet6 addr: fe80::250:8dff:fe53:57b3/64 Scope:Link
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:0 (0.0 b)  TX bytes:378 (378.0 b)
>           Interrupt:201 Base address:0xc000
> So, this went into /etc/dhcp3/dhcpd.conf:
> subnet netmask {
>         range;
> }
> (I get a syntax error without the three zeroes at the end of
>; I also need to check some more and see if the range I
> specified is really sane.) /etc/init.d/dhcp3-server start crashes;
> /var/log/syslog says:
> Jan 10 00:46:27 localhost dhcpd: /etc/dhcp3/dhcpd.conf line 41: subnet
> netmask bad subnet number/mask combination.
> Jan 10 00:46:27 localhost dhcpd: subnet netmask
> Jan 10 00:46:27 localhost dhcpd:                                  ^
> Jan 10 00:46:27 localhost dhcpd: Configuration file errors encountered
> -- exiting
> Okay... I found some articles that "explain netmasks", but they don't
> really go beyond explaining boolean math and binary numbers. :-P I
> already knew that. I want to know why this number/mask combination is
> "bad"!
> So, anybody want to point me in the right direction? Would DHCP 2 have
> been easier to set up? Should I have just done the sane thing and
> tried SuSE or Ubuntu? :-) (I have Slackware, too, but I would be
> surprised if *it's* easier to configure... )
> Speaking of Slackware, I finally figured out why Slackware has such a
> reputation as being hard: The package management system freaking
> DOESN'T SUPPORT DEPENDENCIES! Sorry, that's not for me. :-P I'd
> *never* survive without dependencies...
> William
> _______________________________________________
> talk mailing list
> talk at nblug.org
> http://nblug.org/cgi-bin/mailman/listinfo/talk

More information about the talk mailing list