[NBLUG/talk] HP 5200c scanner, Fedora Core 2, 2.6.5 kernel

Dave Sisley dsisley at arczip.com
Mon Jun 14 07:23:03 PDT 2004


Having just upgraded from FC1 -> FC2, one of the more stubborn
problems I am having is regaining use of my scanner.  It was working
fine before my upgrade.  FC2 uses a 2.6.5 kernel.

I've been googling this quite a bit, and none of the few solutions
seem to work.

I've tried:

- reinstalling sane-frontends, sane-backends, xsane and xsane-gimp

- editing /etc/sane.d/hp.conf in a number of (unsuccessful) ways

Currently, the scanner is detected by sane-find-scanner:

"found USB scanner (vendor=0x03f0, product=0x0401) at libusb:002:002"

Running xsane as myself (lowly user) returns an error message that it
can't find the device.  Running it as root, the program will start,
but I when I try to scan I get this message:

"Error during read: Error during device I/O."  I've been seeing this
message consistently since my upgrade.  Before I reinstalled the
packages mentioned above, I was able to get xsane to run as a lowly
user, but would still get the I/O error.

Has anyone else experienced this problem? More importantly:  has
anyone *solved* this problem?



Dave Sisley
dsisley at arczip.com

More information about the talk mailing list