[NBLUG/talk] Machine Check Exception?

Lincoln Peters sampln at sbcglobal.net
Fri Jun 25 18:43:32 PDT 2004

On Fri, 2004-06-25 at 18:05, Lincoln Peters wrote:
> Actually, I didn't completely explain what I had done.  I tried
> reinstalling from a Debian/woody CD, which contains a different kernel
> (it uses 2.4.18, I was using 2.6.6).  I noticed the same problem with
> both kernels.
> Right now, I'm running the box with the 2.6.6 kernel, trying to compile
> a kernel.  Then I'll try booting from the old 2.4.18 kernel and try a
> similar strenuous operation.  Unless someone can suggest something even
> more strenuous...

Under the 2.4.6 kernel, it produced a kernel panic (but did not crash)
while compiling dma.o, and I found a runaway process called "fixdep"
that, despite even the use of "kill -9", refused to die.  Fortunately, I
was able to switch to a different virtual console and reboot cleanly.

I then booted from the old 2.4.18bf24 kernel that was originally
installed and tried to compile the kernel again.  When it got to
timer_tsc.o, it produced a kernel panic and completely locked up.  I had
to do a hard reset.

> I'll also give it a try with a Knoppix CD.

Still waiting for it to burn on my iBook...

> > 
> > Oh, and regarding RAM testing.  Not sure how you did it, but last year I
> > ran a series of memtest86 cycles on a stick of RAM that I suspected was
> > bad.  It passed.  The machine was still unstable, so I ran memtest86
> > again, this time letting it cycle overnight.  About the 20-something
> > iteration, the RAM started showing errors.  It was indeed bad, and a new
> > stick of RAM "fixed" the machine.
> I used a "CheckIt Express" boot floppy.  I'll look into memtest86,
> though.

I created an memtest86 boot floppy with no difficulty.  Strange.

I booted from the floppy, and it seems to have started testing memory
without any other intervention on my part.  I'm letting it run as I
write this.

Lincoln Peters
<sampln at sbcglobal.net>

More information about the talk mailing list