"funny" ASUS P5A-B-AT motherboard

Mitchell Patenaude mrp at sonic.net
Fri Aug 4 08:45:41 PDT 2000

Last time I saw this, it was because of the old cylinder>1024 bug.
(All files needed for boot, i.e. the kernel and the system map, have
to reside on the disk below cylinder 1024 because of a limitation with
the boot/BIOS spec.)

I redid the drive so that entire root partition was below that cylinder,
and then the problem went away.

I used partition magic to shuffle the partitions around, and it worked like
a champ.

   -- Mitch

On Thu, Aug 03, 2000 at 11:07:15PM -0700, Bob Blick wrote:
> Hi everyone,
> I've been scratching my head a little about this one. Two problems:
> 1. Lilo does not work. Sticks at LI no matter what I put in lilo.conf. I've
> tried with and without linear, appending the drives geometry, putting it in
> the master boot record and also in the first active partition. This is a
> dual-boot machine so currently I just use loadlin so it's not a real
> problem, but curious.
> 2. Only 64 meg ram shows up. I though this was a pre-2.0 kernel thing. If
> lilo worked I could append something in there, but I also tried passing a
> memory line to loadlin and didn't get any complaints(but still only 64 meg
> ram). Could not find any documentation for loadlin so I bet I did it wrong,
> it's the first time I used anything but lilo. The bios has a "OS/2 > 64
> meg" switch but that drops the displayed ram to 16 meg.
> This is the system:
> ASUS P5A-B/AT motherboard (socket 7)
> Onboard CMI8330 audio that hogs 2 interrupts but is a handy aural disk
> activity indicator :-(
> 350MHz AMD K6-2 running 100 MHz bus
> 96 meg ram(3 32 meg SDRAM DIMMS)
> TNT RIVA AGP video card with 16 meg SDRAM
> 3Com 3c905 PCI network card
> hda is WD 10 gig ultra ATA set as LBA in bios with Win95 installed
> hdb is an ATA Iomega Zip drive
> hdc is a WD 2.1 gig EIDE set as CHS in bios, RedHat 6.2(hdc1 is /boot, 17
> megs)
> hdd is a generic EIDE cdrom drive
> Any suggestions welcome. At this point I'm curious about the Lilo problem,
> but would really like to solve the memory issue. The system test reports 96
> meg at start, and Windows finds all 96 meg, just not Linux. I have a
> machine at work running RedHat 5.2 and it finds all its memory, so I tend
> to think it's a chipset issue that I can patch somehow, or if there's a way
> to pass parameters to loadlin I'm all ears.
> Thanks,
> Bob

More information about the talk mailing list