"funny" ASUS P5A-B-AT motherboard

ME dugan at passwall.com
Fri Aug 4 03:32:15 PDT 2000

Appologies to the list as I have been to busy at work to anwer other

On Thu, 3 Aug 2000, Bob Blick wrote:
> 1. Lilo does not work. Sticks at LI no matter what I put in lilo.conf. I've
> tried with and without linear, appending the drives geometry, putting it in
> the master boot record and also in the first active partition. This is a
> dual-boot machine so currently I just use loadlin so it's not a real
> problem, but curious.

A few things:
Eliminate "compact" and "linear" options in the /etc/lilo.conf file
re-run lilo

If it works, cool, no need to try the rest of this.

If we assume that you boot direct from primary IDE master, and you
have tried specifying the boot partition (assuming partition 1) with a
statement in /etc/lilo.conf like:

and running of lilo after making all of the above changes still does not
help, you *may* want to try:


instead. Feel free to dump the contents of your /etc/lilo.conf to this
list. Something might jump out of the page at us, not stated here.

(Good descriptions on your drives/os/partitions btw)

I have had 2 linux boxes that needed the above boot=/dev/hda (well one
with /dev/hda and another needing /dev/sda) before the lilo.conf info was
written to where it needed to be written. 

I would make this suggestion last on your list to try. (See what other
people say before timkering with this part.)

The read-me's often say you should reference the partition like /dev/hda1,
but a number of man pages say:

--- *chop*
       This  file, by default /etc/lilo.conf, is read by the boot
       loader installer lilo (see lilo(8)).

       It might look as follows:

              boot = /dev/hda
              delay = 40
--- *chop*

> 2. Only 64 meg ram shows up. I though this was a pre-2.0 kernel thing. If
> lilo worked I could append something in there, but I also tried passing a
> memory line to loadlin and didn't get any complaints(but still only 64 meg
> ram). Could not find any documentation for loadlin so I bet I did it wrong,
> it's the first time I used anything but lilo. The bios has a "OS/2 > 64
> meg" switch but that drops the displayed ram to 16 meg.

Try adding into /etc/lilo.conf the line:

and re-run lilo. If your changes are not being written to replace the
present copy of lilo, these may prove to be useless.

As for loadlin:

If we assume you have a directory in DOS/Windows "C:\LILO\" and it has
"LOADLIN.EXE"j, and you have a kernel called whee.krn also located in
"C:\LILO\", and we also assume that the root partition is partition 1 of
your secondary IDE interface, then this would be a line to try: 

C:\lilo\loadlin.exe c:\lilo\whee.krn mem=96M root=/dev/hdc1 ro

Sometimes, some BIOS/Video stuff will be shadowed in RAM, or you have one
of those "nifty" motherboards that uses standard RAM for your video
memory, you then need to decrease your memory by the amount used by
BIOS/Video. I have had to work around a few of these, and did not like
them. Though this is a "neat" feature for the average home user, I don't
like it. Say you set in your BIOS to have your video use 8 Mb instead of
4Mb, and then in windows you notice you have 4Mb of RAM less than
before... you have one of these motherboards...

If we assumed that you had one of these, and allocated 8Mb to video,  then
your LOADLIN line might look like this instead:

C:\lilo\loadlin.exe c:\lilo\whee.krn mem=88M root=/dev/hdc1 ro

The above change to memory based on BIOS shadowing/Video memory would
apply for the append line for lilo.conf.

As for dos (assuming you manage to get the bootsector on your primary
master updated), you can look to append the following to make dos an
option in lilo.conf: 

--- *chop*
# For loading dos:
other = /dev/hda1
  label = dos
  table = /dev/hda
--- *chop*

If you make this last, then it won't be the default. The first lilo.conf
entry becomes the default for booting.

> This is the system:
> ASUS P5A-B/AT motherboard (socket 7)
> Onboard CMI8330 audio that hogs 2 interrupts but is a handy aural disk
> activity indicator :-(
> 350MHz AMD K6-2 running 100 MHz bus
> 96 meg ram(3 32 meg SDRAM DIMMS)
> TNT RIVA AGP video card with 16 meg SDRAM
> 3Com 3c905 PCI network card
> hda is WD 10 gig ultra ATA set as LBA in bios with Win95 installed
> hdb is an ATA Iomega Zip drive
> hdc is a WD 2.1 gig EIDE set as CHS in bios, RedHat 6.2(hdc1 is /boot, 17
> megs)
> hdd is a generic EIDE cdrom drive
> Any suggestions welcome. At this point I'm curious about the Lilo problem,
> but would really like to solve the memory issue. The system test reports 96
> meg at start, and Windows finds all 96 meg, just not Linux. I have a
> machine at work running RedHat 5.2 and it finds all its memory, so I tend
> to think it's a chipset issue that I can patch somehow, or if there's a way
> to pass parameters to loadlin I'm all ears.
> Thanks,
> Bob

More information about the talk mailing list