Deja Vu all over again

ME dugan at
Sat Mar 31 19:21:33 PST 2001

(In this message, I have taken to chopping a lot of the lower stuff off to
make messages shorter)

On Sat, 31 Mar 2001, John F. Kohler wrote:
> With Linux 6.2 on the old box with another NIC the router and CAT-5
> cable to it worked fine. Now, I may justifiably be accused of changing
> too many elements in this mix.
> 1)  RH 6.2 to RH 7.0
> 2)Pentium 200 machine to AMD k-6 machine
> 3) a new ethernet NIC in the new computer.
> I plead guilty.  It is probably better to change **one** item at a time in a complex
> system to see if something changes, not **three**

Changing all of the above should not be a problem, except the ethernet
card. It is the only element that is questionable in my opinion. One
sample test might be to remove the present ethernet card, install the old
one and then re-install redhat.

Even if it would work (I am expecting it would) you still would not know
where the problem with the old card was:

1) Physical connection, or physical property of the new card
2) How the linux kernel modules or interface is trying to talk to it.

I lean towards item 1, but only a little bit more than item 2.

> 2) The Linux fails with which ever cable and router port it is using.
> ....Wait a minute!  After a whole bunch of "Destination Host Unreachable" with the linux box on
> its "old" cable and port, it just started working!   We have an intermittent
> problem here...somewhere....

OK, let us assume for now that the connections from the plug to the socket
in the card are not perfect but intermittant... Start a continuous ping
session to the router. Let it continue to run. After you have abot a page
of successful pings (assuming it is still working) strat wiggling the
cable connected to the card. Shift around the jack in the receptical. Note
if any of these has an effect on the pings not going through.

The Ethernet cables you are using:
Are these from Apple computers? Home made? from a reputable source? I had
cases with some Cat-3 cables from apple that use 4 conductors with the
RJ45 jacks refused to work on PCs because Apple crimped the contact points
to far into the conductors/wires for the ethernet card on a PC to make
contionuous contact.
If you have Cat-5 cables, this seems less likely, but is worth examining.

> Redhat 6.2 worked successfully on the Pentium but I am not sure I
> tried it on my new computer (amd -k-6) I probably did not, but I am
> willing to do so.  After all, 6.2 served me long and well on my home
> network with this cable, router, and an older ISA nic ethernet card.

It is very likely using the old NIC will allow you to have linux talk to
your network. However, it does not prove ifthe fault lays with your
"new" card physically or with the linuk kernel's interface to the card.

Where you go from here depends on your direction and purpose. If you just
want the darn thing to work, then try the older card. If you want to
continue to try this new card and see if you can make things work, then I
can keep working with you a bit more. :-)

> > 3) Network service/process or sentry that is not acting like it should
> > (not so likely)
> It is funny, to me, on successful pings to some times I'll get
> 356 out of 427 packets (16% loss) on others:
> 190 packets transmitted, 1 packet received.    I would think
> that the problem would remain constand, i.e., continuous 15% losses across the
> board.
> Here is another puzzler....Just now I pinged ....21 packets sent and
> received   100% success, 0% packet loss.
> Do intermittent problems raise their ugly heads in the ethernet arena?

One thing to point out, you said you had 100% success in pinging your own
IP address in your last statement, not that of the router.

I would expect that ou will have the same lack of success when trying to
ping other machine on your network. When you try sequences of pings to
your macs do you get similar inconsistent ping responses. You could test
this though too. try pinging your macs when they are on and have access
the network over TCP/IP at least once.

> I am capable of screwing the most simple and straightforward installation
> processes. (Incidentally I **don't** have a surge suppressor on my "new"
> PC, so utility line abberations during an installation might just interfere
> with the successful transfer of software from the installation CD to the hard disk.

Though power issues can plague a system with odd problems, I have not yet
seen problems like this as a result of power. (Thanks for suggesting this
as a possiblle issue because volunteering information that you think might
be relavent can be very helpful. :-)

> > Does the ethernet card come with any diagnostic software to
> > test media and the card?
> Yes, but it requires that I boot the PC from a reliable Windows9x/DOS floppy.
> The one I have now is corrupted, partly, and I can't trust it.    I can try to get another,
> maybe from a neighbor, or my son  in Cotati.
> > If you have this diagnostic software and can run
> > it, examine the lights on the back of the card.
> I did run the diagnostic software once, yesterday, successfully. I did
> not notice the LED's on the back of the NIC.

We might revisit these test more later. Since you have run them recently
and the software found no problems, a new "retest" is unlikely to show
better results.

More information about the talk mailing list